Era Security: Greeter, a Chinese-language exploitation framework, abused Flowise overrideConfig (CVE-2024-58351) on honeypots from July to October 2026 to pull AWS credentials, cloud metadata and host recon via "hello" chat messages
Era Security published on 3 November 2026 that its researchers observed a Chinese-language exploitation framework, which they named Greeter, targeting Flowise — an open-source agentic development platform — on a network of seven honeypots across four regions between July and October 2026.
Era says every stored user message in the captured conversations (4,972 in total) was the word "hello", while the responses contained user identities, AWS credentials, cloud metadata probe results, process listings, network information and credential-file paths; Era says Greeter sent rapid messages about 3.5 seconds apart, each delivering malicious commands.
Era says Greeter exploited CVE-2024-58351 in Flowise's runtime configuration mechanism (overrideConfig), which lets an attacker override JavaScript instructions for some Flowise API endpoints without modifying the saved chatflow, so the chatflow looks harmless while the API returns execution results.
Era queried Shodan for internet-exposed Flowise instances and reports 4,372 unique hosts, 3,277 with a recognizable version, 703 (21.5%) with no authentication, and 46 unauthenticated instances that appeared to match the vulnerable conditions Era recreated in its honeypots; Era presents those as version-based exposure estimates, not confirmed compromises. Era also lists several other Flowise CVEs with high version-based exposure shares on the same Shodan set.
GitHub's reviewed advisory GHSA-5cph-wvm9-45gj for CVE-2024-58351 rates the issue High (CVSS 8.6), says npm package flowise versions before 2.1.4 are affected, and lists 2.1.4 as the patched version; Era's honeypots ran Flowise 1.8.2. (sources: Era Security; GitHub Advisory Database GHSA-5cph-wvm9-45gj)
- Product
- Flowise (npm flowise) — open-source agentic / LLM orchestration platform
- Versions
- CVE-2024-58351: GitHub advisory says affected < 2.1.4, patched 2.1.4. Era honeypots ran Flowise 1.8.2 with FLOWISE_USERNAME/PASSWORD undefined.
- CVSS
- High 8.6 (GitHub Advisory GHSA-5cph-wvm9-45gj; CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N)
- Exploited in Australia?
- unknown
- Patch to
- Upgrade Flowise to 2.1.4 or later (GitHub advisory). Do not expose unauthenticated Flowise prediction APIs to the internet; require auth; treat overrideConfig as dangerous on any older build. Era publishes host/chatflow IoCs (polld-keeper-*, varrun-watcher-*, cron/systemd persistence paths, VP_* status markers) for defenders reviewing Flowise logs.
